Создаем собственную справку

14 апреля 2013

Тестовая конфигурация с примером

Предисловие

Пишите отчет для продажи или целую подсистему для типовой конфигурации? Тогда обязательно напишите толковую справку для добавляемых объектов конфигурации или напишите пользователям свой сотовый телефон. Ведь вопросов у них будет очень много! (Будем основываться на том, что мы живем в идеальном мире, где пользователи читают справочную информацию прежде чем звонить в техподдержку или программисту).

В статье рассмотрим простые примеры по созданию справочной информации для объектов конфигурации, а также программную работу со справкой.

Добавляем справку

В тестовой конфигурации содержится справочник "Товары" и обработка для его заполнения "Заполнение справочника товары".

Для этих двух объектов необходимо добавить краткую справочнику информацию. При этом в справке к справочнику "Товары" должна быть добавлена ссылка на справку обработки заполнения товарами. Для этого в справочнике "Товары" перейдем на закладку "Прочее". Установим опцию "Включать в содержимое справки".

При нажатию по ссылке "Заполнение справочника товаров" пользователь будет переведн на справочную информацию обработки. Она заполнена следующим образом:

Добились мы этого путем помещения ссылки в справку. Для этого в окне редактирования справочной информации необходимо выделить текст, который нужно сделать гиперссылкой, и выполнить команду меню "Элементы->Ссылка". В появившемся окне выбрать обработку из метаданных конфигурации "Заполнение справочника товаров".

На этом реализация каркаса справочной системы в рамках примера завершена. Ранее мы устанавливали опцию "Включать в содержание справки". Эта опция позволяет включать в стандартное оглавление справки свои элементы. Для этого нужно создать дерево подсистем и включить в их состав соответствующие объекты. В тестовой конфигурации создаем иерархию, выделяем отдельно каждый объект. Аналогичным образом поменяется содержимое оглавления справки.

На этом каркас справочной системы для нашего примера реализован. Перейдем к программной работе со справкой.

Программный вызов справки

На форму списка справочника "Товары" добавим следующие команды:

Первая команда - вызывает справку об объекте конфигурации "Справочник", вторая - информацию по справочнику "Товары", добавленную нами ранее. Третья - вызывает раздел встроенной справки о фирме "1С". Справка формы - вызывает раздел справки, связанный с текущей формой. На следующем листинге приведен программный код обработчиков каждой из этих команд:

&НаКлиенте
Процедура ЧтоТакоеСправочник(Команда)
	// Работает только в толстом клиенте, так как с метаданными можно работать либо на сервере
	// либо в толстом клиенте
	ОткрытьСправку(Метаданные.Справочники);    	
КонецПроцедуры
&НаКлиенте
Процедура ПоТоварам(Команда)
	// Вызов справки по справочнику "Товары"
	ОткрытьСправку("Справочник.Товары"); 	
КонецПроцедуры
&НаКлиенте
Процедура СправкаФормы(Команда)
	// Вызов раздела справки, связанного с текущей формой
	ОткрытьСправкуФормы(); 	
КонецПроцедуры
&НаКлиенте
Процедура ОФирме1С(Команда)
	// Открываем встроенный в платформу раздел справки "О фирме 1С"
	ОткрытьСправку("v8help://1cv8/1C_Corporation"); 
КонецПроцедуры

Все примеры вызова справки достаточно просты. Единственный момент - получение ссылки на встроенный в платформу раздел справки. Для этого при выборе ссылки в редакторе справочной информации нужно указать раздел справки платформы. Ссылка на него появится в окне выбора.

На этом о программной работе со справкой все.

Лучше один раз написать, чем сто раз объяснить!

Экономьте свое время! Написание хорошего мануала поможет пользователям программы быстрее разобраться в функционале и убережет Вас от повторяющихся вопросов.


comments powered by Disqus